Get in touch
Back
Maintenance

Web server host maintenance

Completed 3 Jan at 03:43pm CET.

Main webpage FelixBot SMTP IMAP
Completed

The maintenance has finished.

Posted 3 Jan at 03:43pm CET.
Updated

The maintenance also affects our mail servers

Posted 3 Jan at 03:38pm CET.
Started

Our web server host will be undergoing maintenance for approximately 10 minutes, during which affected services will be unavailable.

Posted 3 Jan at 03:30pm CET.