Get in touch
Back
Maintenance

Full systems maintenance

Completed 3 Jan at 10:00pm CET.

Main webpage FelixBot SMTP IMAP
Completed

Maintenance completed

Posted 3 Jan at 10:00pm CET.
Started

We're performing full-scale network and system maintenance and thus our services will be temporarily unavailable.

Posted 3 Jan at 07:10pm CET.